Category: Docker

Docker Technology Fans

Docker communication to hardware on host

I’m trying to learn some things about Docker. Right now, I’m asking myself, if a Docker container can communicate with something like a camera from the host. Can anyone answer me that, and say how to pls?

Use Docker Compose offline by using local images and not pulling images

I want to issue the docker-compose command to bring up all the dependent service containers that I have previously pulled down while inside the company network. I am outside the company network so when I try to start my environment the first thing it does is try to call out to the company network and […]

Running ubuntu containers on ubuntu host – application with gui

I have a Ubuntu host and top of it I run a ROS rocker container. http://wiki.ros.org/docker/Tutorials/Docker These ROS applications generally have a Linux GUI application. I’m wondering how to have this GUI enabled in my container. This is the kind of output the ROS container will have. http://wiki.ros.org/ROS/Tutorials/UnderstandingNodes#line-1-12

Kubernetes cronjob reports “found invalid field” for failed and successfuJobsHistoryLimit

I created a CronJob in my Kubernetes cluster that is working fine. I tried to add the spec fields for successfulJobsHistoryLimit and failedJobsHistoryLimit. Based on the documentation at https://kubernetes.io/docs/concepts/workloads/controllers/cron-jobs/, they should be at the top level spec section, but I am getting the error when applying: error validating data: [found invalid field successfulJobsHistoryLimit for v2alpha1.CronJobSpec, […]

How to restore Docker images after “Reset Factory Settings”?

I had a problem with launching Docker, and looks like Reset Factory Setting deletes data as well reseting Docker settings. Is there any way to retrieve my images? I can see the following in my trashcan: Docker (17656).app.

Bootstrapping large amounts of media for a Docker container

I’m working on setting up a project in Docker, with a stack file defined for one-click (ish) deployments of already-configured UAT environments. In order to set this up, I need to seed the environment with 7GB worth of assets. I’ve tried to solve this problem with a data-only container that dumps the data in a […]

mingw in docker container no output

I obviously do something wrong. Or threre is a bug. Anyway, on recent docker 17.03.1-ce, run various windows containers, e.g.: docker run -it microsoft/windowsservercore and see no output for mingw and cygwin tools: C:\test>dir Volume in drive C has no label. Volume Serial Number is 0E7C-C210 Directory of C:\test 06/27/2017 08:43 AM <DIR> . 06/27/2017 […]

Persistent Storage with Docker in Production – Which Solution and Why? [closed]

I’ve recently started working for a company that wants to break their monolithic SaaS application up into containerized microservices. I’m having a hard time grasping a fundamental part of persistent storage, though. Why are there so many different competing platforms? Portworx, Rexray, StorageOS, Flocker, Inifint, etc. My Questions Why wouldn’t someone simply spin up an […]

How to set proxy on rstudio from dockerhub behind a proxy?

I downloaded rocker/tidyverse from dockerhub. I tried installing a package and was greeted with: URL ‘https://cran.rstudio.com/src/contrib/PACKAGES.rds’: status was ‘Couldn’t connect to server’ After logging into rstudio, I tried executing all the commands shown here: https://support.rstudio.com/hc/en-us/articles/226914208-Installing-packages-on-RStudio-Connect-from-behind-a-proxy Though I still get the same error. How can I set my proxy to be able to install packages? Update: […]

Docker error The command non-zero code: 1 python

i have problem when i tried to build container. And the error is : The command ‘/bin/sh -c pip install -r requirements.txt’ returned a non-zero code: 1 i don’t know why, i follow the code from documentation but always get error. Dockerfile FROM python:2.7-slim # # # Set the working directory to /app WORKDIR /app […]

Docker will be the best open platform for developers and sysadmins to build, ship, and run distributed applications.