Category: Docker

Docker Technology Fans

Restart Postgres in a docker

I tried to restart Postgres in Docker using ‘docker restart ‘ command. It got stopped but I’m not able to start it. When I run the command ‘ps -a’ it says the status as ‘Exited’. Is there any way to start it again? I don’t want to loose any data in that database. The container […]

docker saved image, how to run?

I have a testlink docker image running (named ‘otechlabs/testlink’). Question 1: How do I get the original url from which I downloaded it (I can’t remember) ? I would like to see the instructions about how to run the container. It’s running so fine that I saved a commit of it to run in another […]

Golang docker library image cannot find go tool in $PATH

I opened an issue on docker-library/golang#164, because I think this is a bug. However, I thought I’d also ask on StackOverflow to see if anyone else (besides project contributors) have encountered this or have any ideas? First things first, the version numbers: $ docker version Client: Version: 17.03.1-ce API version: 1.27 Go version: go1.7.5 Git […]

Intellisense for python dependencies installed in docker containers?

I’ve been using docker for a while but I have a small issue with the editor i’m using(VSCode). Pylint will show an error that module X obviously isn’t found because the vscode is relying on the local python interpreter and not the remote one in the docker container. It seems that pycharm is the only […]

Accesing Spring-Boot WebApplication running in Docker Container

so I got a running Spring-Boot Application that is deployed into a Docker container. I mapped the port of the application to a port on my portainer which runs multiple Docker container. Everything seems fine but if i try to acces the WebApplication i get a Connection Refused Error. Mapping of Docker Port to Application […]

How to Resolve Unable To Login Docker

Following a Docker guides, I try to build a Docker with a command sudo gradle build buildDocker and I get an error: What went wrong: Execution failed for task ‘:buildDocker’. Docker execution failed Command line [docker push vw98075/demo-docker-postgresql:0.0.1-SNAPSHOT] returned: denied: requested access to the resource is denied Based on an information on this site, I […]

Docker: Compressing Directories in Image

I want to minimize image files for docker. I basically found out that much of my image is compressible so the question goes, if one can use a kind of a compressed file system within the docker images. When exporting an image of a container as a tar one notice that the content of the […]

How to log in gcloud with a dockerfile

I would like to log to gcloud when building a container with dockerfile. RUN gcloud auth application-default login Seems pretty obvious but how to get the url link ? Should i have to make a script to execute this command and mail me the link ? Thanks and Regards

docker swarm certificate expiry

I am trying to create a docker swarm that has certificates that expire after 1 year or more. The documentation states the syntax and I tried this docker swarm init –cert-expiry 8760h0m0s However under cat /var/lib/docker/swarm/certificates/swarm-node.crt when I decipher the certificate the validity is still 3 months. How do I make sure that validity is […]

Dockerfile entrypoint

I’m trying to customize the docker image presented in the following repository https://github.com/erkules/codership-images I created a cron job in the Dockerfile and tried to run it with CMD, knowing the Dockerfile for the erkules image has an ENTRYPOINT [“/entrypoint.sh”]. It didn’t work. I tried to create a separate cron-entrypoint.sh and add it into the dockerfile, […]

Docker will be the best open platform for developers and sysadmins to build, ship, and run distributed applications.