Category: Docker

Docker Technology Fans

Kubernetes configuration to link containers

I am trying to see if there are any example to create a Kubernetes POD which starts 2-3 containers and these containers are linked with each other but couldn’t find any. Does anybody tried linking containers using Kubernetes config.

Unable to start TensorFlow within Docker, on Windows

Hope I didn’t miss anything. I’ve installed docker on my win 7 using this guide: I opened a new terminal and entered the following command: docker run -it All donwloaded and extracted and then I get the following massages: [I 16:09:55.069 NotebookApp] Writing notebook server cookie secret to /root/.local/share/jupyter/runtime/notebook_cookie_secret [W 16:09:55.122 NotebookApp] WARNING: […]

Boot2Docker on Mac – Accessing Local Files

I’ve just set up boot2docker on my Mac. How do I go about mounting a local directory on my Mac so that it’s accessible all the way through to a running Docker container? Thanks for your help!

How to set Java heap size (Xms/Xmx) inside Docker container?

As of raising this question, Docker looks to be new enough to not have answers to this question on the net. The only place I found is this article in which the author is saying it is hard, and that’s it.

Get docker container id from container name

What is the command to get the docker container id from the container name?

Resource Usage by stopped Docker containers

Docker makes it easy to stop & restart containers. It also has the ability to pause and then unpause containers. The Docker docs state When the container is exited, the state of the file system and its exit value is preserved. You can start, stop, and restart a container. The processes restart from scratch (their […]

docker RUN append to /etc/hosts in Dockerfile not working

I have a simple Dockerfile but the first RUN command (to append a host IP address to /etc/hosts) has no effect FROM dockerfile/java RUN sudo echo “XX.XX.XXX.XXX MyFriendlyBoxName” >> /etc/hosts ADD ./somejavaapp.jar /tmp/ #CMD java -jar /tmp/somejavaapp.jar EXPOSE 8280 I build using docker build . and then test the RUN echo line has worked […]

Docker install fails on OSx

I am trying to install new Docker on OSx. It fails with following error. Installation Failed. Also the window opens where I can see two utilities: Docker Quick Terminal Kinematic When I click Docker Quick Terminal I can type: docker info But when I type: docker run I get the error. sudo docker run -i […]

How to access the VM created by docker's HyperKit?

Docker for Mac uses a Linux VM created by HyperKit for storing and running containers on Mac. With Docker Toolbox, I can just open VirtualBox and access the docker-machine VM. But with Docker for Mac, how do I access the VM created by HyperKit?

Keep getting Could not read CA certificate when trying to start docker

I am attempting to migrate from boot2docker to docker-machine. I followed the directions here to install docker but I keep getting the following message: Could not read CA certificate “/Users/<useraccountfolder>/.boot2docker/certs/boot2docker-vm/ca.pem”: open /Users/<useraccountfolder>/.boot2docker/certs/boot2docker-vm/ca.pem: no such file or directory when I run most any docker command.

Docker will be the best open platform for developers and sysadmins to build, ship, and run distributed applications.