Symfony 3 assets no update

I’ve init new projet in Symfony 3 with nginx and docker. It worked nice but my assets doesn’t update in web/assets/bundle.js. Is i check my bundle.js after update, i see the old version.

I’ve remove the Symfony cache and my browser, but no result :

  • Docker on Windows and Samba/CIFS
  • Upgrade from Docker 1.08 to 1.10
  • Accessing host different ports in production
  • Crypt32.dll not found for awssdk in .net core running in docker
  • Elastic Search Multiple Publish Host
  • How to restart kubernetes Pods?
  • php bin/console assets:install

    My nginx config :

    worker_processes 4;
    pid /run/;
    events {
      worker_connections  2048;
      multi_accept on;
      use epoll;
    http {
      server_tokens off;
      sendfile on;
      tcp_nopush on;
      tcp_nodelay on;
      keepalive_timeout 15;
      types_hash_max_size 2048;
      include /etc/nginx/mime.types;
      default_type application/octet-stream;
      access_log off;
      error_log off;
      gzip on;
      gzip_disable "msie6";
      include /etc/nginx/conf.d/*.conf;
      include /etc/nginx/sites-enabled/*;
      open_file_cache max=100;

    And Symfony :

    server {
        listen   80; ## listen for ipv4; this line is default and implied
        listen   [::]:80 default_server ipv6only=on; ## listen for ipv6
        server_name myApp.local;
        root /var/www/lfdw/web;
        location ~ ^(.*)/(app|app_dev|app_test|config)\.php(/|$) {
            fastcgi_pass php-upstream;
            fastcgi_split_path_info ^(.+\.php)(/.*)$;
            include fastcgi_params;
            fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
            fastcgi_param HTTPS off;
        error_log /var/log/nginx/symfony_error.log;
        access_log /var/log/nginx/symfony_access.log;

    Do you have any idea ?

    Thank you !

  • Copy files from ftp to docker container
  • Write GET request for docker
  • Docker --tag vs --name clarification
  • Amazon AWS ECS Docker Port not binding correctly
  • docker-compose build error when using parent dir & dockerfile for build
  • Problems running npm install during docker-compose build
  • One Solution collect form web for “Symfony 3 assets no update”

    I had this problem on a local install the new assets wouldn’t install at all.what i did was deleting the whole bundles directory in web and regenerated the assets.

    Another hacky way would be to delete your vendors and composer install

    If you are in prod you probably just need to execute this command:

    app/console assetic:dump --env=prod --no-debug

    Docker will be the best open platform for developers and sysadmins to build, ship, and run distributed applications.