Official Jenkins Dockerfile acting strange

I want to use the official jenkins docker image from here :
https://github.com/jenkinsci/docker/tree/62de121e41ddd92ef34e9999162932334b05f0d7
and further customize it.

When i just launch a container with docker run -d -p 8080 jenkins , it plays ok.
But when I download all the project and build it locally [as it is,without changing anything], when I launch a container it exits right after launch.

  • Setting up three docker images - one as a proxy to the other two
  • How can Services running in a Docker VM and running on localhost register at EUREKA dynamically?
  • How to make host interfaces, including cni* accessible in kubernetes privileged pods?
  • Patterns for Docker DB Snapshot
  • How to execute a script when I terminate a docker container
  • How to manage Docker private registry
  • Am I doing something wrong???

  • Why Can I not resolve docker.io and other hosts behind proxy from within Vagrant VM
  • Redis connection failing
  • docker-compose up fails with “ Unable to find a node that satisfies the following conditions ”
  • How to access boot2docker-ip from inside a docker container
  • Connecting to Oracle XE running on Docker
  • Ghost Blog on Ubuntu Snappy Core OS
  • One Solution collect form web for “Official Jenkins Dockerfile acting strange”

    are you’re using Docker Toolbox on Windows?

    If yes, be carreful with end of line different between Windows and Linux.

    Try to clone repository like this

    git clone myrepo --config core.autocrlf=false
    
    Docker will be the best open platform for developers and sysadmins to build, ship, and run distributed applications.