Docker missing files in volumes due to encoding

I am running boot2docker on Mac. I have started a container mounting a volume from my Mac to the container using -v command.

Problem is, all files with special encoded characters simply don’t appear in the volume from within the container. The left part of the screenshot is ls from my Mac, and the right is ls from within the container.
screenshot

  • How to pull image from custom docker registry with golang?
  • Fail to connect mysql in running wordpress docker
  • How to get ssh connection with docker container on OSX(boot2docker)
  • Couldn't start exited docker container after restart of host machine
  • Send request from one docker container to another
  • Cannot pull same image after aborting Docker pull once: Layer already being pulled by another client. Waiting
  • It seems to me files with encoding, in this case “√Ątt-Arlech-75×75.png” is simply ignored when mounted – how can that be explained, and avoided?

  • how to do network isolation among different applications in kubernetes or in docker cluster?
  • Docker: what is the equivalent of the legacy --link parameter
  • mysql_install_db in Docker container returns error
  • docker-machine ssh command for mongodump
  • What's the difference when installing docker with 2 of these following command?
  • Docker cloud not find images after location changed
  • Docker will be the best open platform for developers and sysadmins to build, ship, and run distributed applications.