ansible docker module: unsupported parameter docker_api_version

Because of different Docker API versions on my machine and the target server, I have to specify the version in my task, as for https://github.com/ansible/ansible-modules-core/issues/705

Here’s my task:

  • Can't push docker image to gcloud
  • Docker compose version 2.1+ on mac
  • How to circumvent “Read-only file system” error on Docker version 0.11 or greater when running sysctl -w during an image build?
  • GKE kuberentes uploading yaml file with docker image error
  • How to start docker container after succesfull wait-for-it script
  • How to specify docker image's DNS?
  • - name: stop the running container
      docker: 
        docker_api_version: 1.13
        image: my_image
        name: my_container
        state: absent
    

    returns the error:

    msg: unsupported parameter for module: docker_api_version
    

    I’m using ansible 1.7.2, and the parameter appears in the documentation for 1.4 http://docs.ansible.com/docker_module.html

  • Faillure to launch docker on OSX Yosemite
  • RabbitMQ inside docker won't end gracefully and cannot reconnect
  • how can I open a flask app on my browser that's running remotely on docker?
  • docker command not found even though installed with apt-get
  • Python exceptions in Docker logs marked as stream: stdout
  • docker: 'network' is not a docker command
  • One Solution collect form web for “ansible docker module: unsupported parameter docker_api_version”

    The documentation for docker_api_version reads “added in Ansible 1.8”. (See comments section on the page you linked http://docs.ansible.com/docker_module.html)

    Docker will be the best open platform for developers and sysadmins to build, ship, and run distributed applications.